1. 28 Aug, 2012 36 commits
  2. 27 Aug, 2012 3 commits
    • Iustin Pop's avatar
      Merge branch 'devel-2.6' · 951accad
      Iustin Pop authored
      
      
      * devel-2.6:
        Make stable-2.6 compatible with newer pep8
        Fix computation of disk sizes in _ComputeDiskSize
        Add verification of RPC results in _WipeDisks
        Add test for checking that all gnt-* subcommands run OK
        Fix double use of PRIORITY_OPT in gnt-node migrate
        Add new Makefile target to rebuild the whole dist
        rapi client: accept arbitrary shutdown arguments
        Handle offline nodes for "instance down" checks
        Add missing rst files to Makefile.am
        Release version 2.6.0 (final)
        Fix 'explicitely' common typo
        Fix issue in LUClusterVerifyGroup with multi-group clusters
        Add QA test for node group modification of ndparams
        Fix node group modification of node parameters
        Fix RST formatting in NEWS file
        Update NEWS and bump version for release 2.5.2
        Fix boot=on flag for CDROMs
        KVM: only pass boot flag once
        Ensure a stable content of the bash completion file
      
      Conflicts (all trivial):
              Makefile.am  (design drafts on both sides, pep8 changes)
              autotools/build-bash-completion (copyright years)
      Signed-off-by: default avatarIustin Pop <iustin@google.com>
      Reviewed-by: default avatarRené Nussbaumer <rn@google.com>
      951accad
    • Iustin Pop's avatar
      Merge branch 'stable-2.6' into devel-2.6 · b5df6331
      Iustin Pop authored
      
      
      * stable-2.6:
        Make stable-2.6 compatible with newer pep8
        Fix computation of disk sizes in _ComputeDiskSize
        Add verification of RPC results in _WipeDisks
        Add test for checking that all gnt-* subcommands run OK
        Fix double use of PRIORITY_OPT in gnt-node migrate
        Add new Makefile target to rebuild the whole dist
      Signed-off-by: default avatarIustin Pop <iustin@google.com>
      Reviewed-by: default avatarRené Nussbaumer <rn@google.com>
      b5df6331
    • Iustin Pop's avatar
      Make stable-2.6 compatible with newer pep8 · 2fefc557
      Iustin Pop authored
      
      
      This is done so that all current branches can run with newer pep8;
      note that instead of fixing the problems (like I did on master), I've
      just silenced more. These should *not* be merged onto master!
      Signed-off-by: default avatarIustin Pop <iustin@google.com>
      Reviewed-by: default avatarRené Nussbaumer <rn@google.com>
      2fefc557
  3. 24 Aug, 2012 1 commit