Commit 3ff614e2 authored by Guido Trotter's avatar Guido Trotter
Browse files

Require aclocal 1.11.1 or above for devel/release



1.11.1 is the version in squeeze and lucid, and we know it works. We
also know that 1.10.1 in hardy and lenny doesn't, nor do 1.10 in etch
and 1.9.6 in dapper. We haven't tested any other version.

With older versions python.m4 is buggy, and results in the package being
built not working on python 2.6 (which uses dist-packages rather than
site-packages as a module directory).

Version comparison is done component-by-component, over a bash array.
Signed-off-by: default avatarGuido Trotter <ultrotter@google.com>
Reviewed-by: default avatarMichael Hanselmann <hansmi@google.com>
parent df304c82
......@@ -46,6 +46,26 @@ echo "Cloning the repository under $TMPDIR ..."
git clone -q "$URL" dist
cd dist
git checkout $TAG
# Check minimum aclocal version for releasing
MIN_ACLOCAL_VERSION=( 1 11 1 )
ACLOCAL_VERSION=$(${ACLOCAL:-aclocal} --version | head -1 | \
sed -e 's/^[^0-9]*\([0-9\.]*\)$/\1/')
ACLOCAL_VERSION_REST=$ACLOCAL_VERSION
for v in ${MIN_ACLOCAL_VERSION[@]}; do
ACLOCAL_VERSION_PART=${ACLOCAL_VERSION_REST%%.*}
ACLOCAL_VERSION_REST=${ACLOCAL_VERSION_REST#$ACLOCAL_VERSION_PART.}
if [[ $v -eq $ACLOCAL_VERSION_PART ]]; then
continue
elif [[ $v -lt $ACLOCAL_VERSION_PART ]]; then
break
else # gt
echo "aclocal version $ACLOCAL_VERSION is too old (< 1.11.1)"
exit 1
fi
done
./autogen.sh
./configure
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment