Commit df304c82 authored by Guido Trotter's avatar Guido Trotter
Browse files

Revert "Require aclocal 1.11.1 or above for autogen.sh"

The comparison is incorrect, and the check also breaks daily work on
autobuilders and older distros.

This reverts commit dbc4dda7

.
Signed-off-by: default avatarGuido Trotter <ultrotter@google.com>
Reviewed-by: default avatarIustin Pop <iustin@google.com>
parent 2d93a6a7
#!/bin/bash
#!/bin/sh
if test ! -f configure.ac ; then
echo "You must execute this script from the top level directory."
......@@ -9,14 +9,6 @@ set -e
rm -rf config.cache autom4te.cache
ACLOCAL_VERSION=$(${ACLOCAL:-aclocal} --version | head -1 | \
sed -e 's/^[^0-9]*\([0-9\.]*\)$/\1/')
if [[ "$ACLOCAL_VERSION" < "1.11.1" ]]; then
echo "aclocal version $ACLOCAL_VERSION is too old (< 1.11.1)"
exit 1
fi
${ACLOCAL:-aclocal} -I autotools
${AUTOCONF:-autoconf}
${AUTOMAKE:-automake} --add-missing
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment