Commit a40b1fc4 authored by René Nussbaumer's avatar René Nussbaumer
Browse files

Adding new (optional) dependency to configure.ac


Signed-off-by: default avatarRené Nussbaumer <rn@google.com>
Reviewed-by: default avatarMichael Hanselmann <hansmi@google.com>
parent 2089573e
......@@ -34,6 +34,8 @@ Before installing, please verify that you have the following programs:
<http://starship.python.net/crew/theller/ctypes/>`_, if running on
python 2.4 (optional, used for node daemon memory locking)
- `socat <http://www.dest-unreach.org/socat/>`_
- `Paramiko <http://www.lag.net/paramiko/>`_, if you want automated SSH
setup; optional otherwise but manual setup of the nodes required
These programs are supplied as part of most Linux distributions, so
usually they can be installed via the standard package manager. Also
......
......@@ -317,6 +317,13 @@ AC_PYTHON_MODULE(pyparsing, t)
AC_PYTHON_MODULE(pyinotify, t)
AC_PYTHON_MODULE(pycurl, t)
# This is optional but then we've limited functionality
AC_PYTHON_MODULE(paramiko)
if test "$HAVE_PYMOD_PARAMIKO" = "no"; then
AC_MSG_WARN([You do not have paramiko installed. While this is optional you
have to setup SSH and noded on the joining nodes yourself.])
fi
AC_CONFIG_FILES([ Makefile ])
AC_OUTPUT
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment