Commit 432d62a8 authored by Helga Velroyen's avatar Helga Velroyen
Browse files

Make configure check for haskell vector library


Signed-off-by: default avatarHelga Velroyen <helgav@google.com>
Reviewed-by: default avatarMichele Tartara <mtartara@google.com>
parent 405656b7
......@@ -504,6 +504,7 @@ if test "$enable_confd" != no; then
AC_GHC_PKG_CHECK([Crypto], [], [CONFD_PKG="$CONFD_PKG Crypto"])
AC_GHC_PKG_CHECK([text], [], [CONFD_PKG="$CONFD_PKG text"])
AC_GHC_PKG_CHECK([hinotify], [], [CONFD_PKG="$CONFD_PKG hinotify"])
AC_GHC_PKG_CHECK([vector], [], [CONFD_PKG="$CONFD_PKG vector"])
if test -z "$CONFD_PKG"; then
has_confd=True
elif test "$enable_confd" = check; then
......@@ -556,6 +557,7 @@ AC_GHC_PKG_CHECK([test-framework-quickcheck2], [], [HTOOLS_NODEV=1])
# that are needed to execute the tests, avoiding the duplication
# of the checks.
AC_GHC_PKG_CHECK([attoparsec], [], [HTOOLS_NODEV=1])
AC_GHC_PKG_CHECK([vector], [], [HTOOLS_NODEV=1])
if test -n "$HTOOLS_NODEV"; then
AC_MSG_WARN(m4_normalize([Required development modules were not found,
you won't be able to run Haskell unittests]))
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment