Commit 099e9213 authored by Iustin Pop's avatar Iustin Pop
Browse files

Update required pylint version



This should help a lot of users, since pylint 0.21.1 was quite an old
version…

The tree is "clean" w.r.t. the new pylint version.
Signed-off-by: default avatarIustin Pop <iustin@google.com>
Reviewed-by: default avatarMichele Tartara <mtartara@google.com>
parent 1498270e
......@@ -29,14 +29,16 @@ Note that for pylint, at the current moment the following versions
must be used::
$ pylint --version
pylint 0.21.1,
astng 0.20.1, common 0.50.3
pylint 0.25.1,
astng 0.23.1, common 0.58.0
The same with pep8, other versions may give you errors::
$ pep8 --version
1.2
Both these versions are the ones shipped with Debian Wheezy.
To generate unittest coverage reports (``make coverage``), `coverage
<http://pypi.python.org/pypi/coverage>`_ needs to be installed.
......@@ -46,9 +48,9 @@ Installation of all dependencies listed here::
$ apt-get install pandoc python-epydoc graphviz
$ cd / && sudo easy_install \
sphinx \
logilab-astng==0.20.1 \
logilab-common==0.50.3 \
pylint==0.21.1 \
logilab-astng==0.25.1 \
logilab-common==0.58.0 \
pylint==0.23.1 \
pep8==1.2 \
coverage
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment