Commit a05a9215 authored by Giorgos Korfiatis's avatar Giorgos Korfiatis
Browse files

Use kamaki 0.13.5 to fix ssl issue

parent 41998bb0
......@@ -32,9 +32,6 @@ from kamaki.clients.astakos import AstakosClient
from kamaki.clients.pithos import PithosClient
from kamaki.clients.utils import https
# this will be deleted when kamaki 0.13.5 is out
from kamaki.clients.astakos import AstakosClientError
logger = logging.getLogger(__name__)
......@@ -80,17 +77,6 @@ def ssl_fall_back(method):
'Kamaki SSL failed, fall back to certifi (mozilla certs)')
https.patch_with_certs(os.path.join(RESOURCES, 'cacert.pem'))
return method(self, *args, **kwargs)
# this will be deleted when kamaki 0.13.5 is out
except AstakosClientError as ace:
logger.debug('Kamaki failed with error %s' % ace)
if '[Errno 2]' in ace.message:
logger.info(
'Kamaki SSL failed with AstakosClientError [Errno 2], '
'fall back to certifi (mozilla certs)')
https.patch_with_certs(os.path.join(RESOURCES, 'cacert.pem'))
return method(self, *args, **kwargs)
else:
raise
return wrap
......
......@@ -36,7 +36,7 @@ CLASSIFIERS = []
# Package requirements
INSTALL_REQUIRES = [
'kamaki>=0.13.4',
'kamaki>=0.13.5',
'watchdog',
'psutil',
'ws4py',
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment