Commit 207ab0e7 authored by Kostas Papadimitriou's avatar Kostas Papadimitriou
Browse files

Update setup.py dependencies

- bump snf-common required version
- replace ampqlib to puka
parent 7018425b
......@@ -73,9 +73,9 @@ INSTALL_REQUIRES = [
'IPy>=0.70',
'South>=0.7',
'pycrypto>=2.1.0',
'amqplib>=0.6.1',
'puka',
'python-daemon>=1.5.5, <1.6',
'snf-common>=0.9.0',
'snf-common>0.9.14',
'vncauthproxy>=1.2',
'south>=0.7, <=0.7.3',
'snf-pithos-backend>=0.9.1',
......@@ -83,7 +83,7 @@ INSTALL_REQUIRES = [
]
EXTRAS_REQUIRES = {
'DISPATCHER': ['amqplib==0.6.1', 'python-daemon==1.5.5', 'lockfile==0.8'],
'DISPATCHER': ['puka', 'python-daemon==1.5.5', 'lockfile==0.8'],
'SSH_KEYS': ['pycrypto==2.1.0'],
'BURNIN': ['unittest2==0.5.1', 'paramiko==1.7.6', 'python-prctl==1.3.0']
}
......
......@@ -60,9 +60,10 @@ setup(
packages=["synnefo", "synnefo.ganeti", "synnefo.versions"],
dependency_links = ['http://docs.dev.grnet.gr/pypi'],
install_requires=[
'snf-common>0.9.14',
'python-daemon>=1.5.5',
'pyinotify>=0.8.9',
'amqplib>=0.6.1',
'puka',
'python-prctl>=1.1.1',
],
entry_points = {
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment