1. 06 Jul, 2015 1 commit
  2. 03 Jul, 2015 1 commit
    • Helga Velroyen's avatar
      Trigger renew-crypto on downgrade to 2.11 · 9d1c128b
      Helga Velroyen authored
      With the upcoming changes in 2.12, is it necessary to run
      'gnt-cluster renew-crypto --new-node-certificates'. To
      ensure that our QA runs smoothely, this means that this
      command needs to be added to the post-upgrade hooks of
      2.11. To ensure that it is only run when coming from
      2.12.X or from before 2.11, the utility functions are
      extended by an equal operator for versions.
      
      Note that it is unlikely that 2.11 will get another release,
      so this is mainly to fix our QA. However, users downgrading
      to a previous version of 2.11 will get a nagging message
      to re-run renew-crypto manually.
      Signed-off-by: default avatarHelga Velroyen <helgav@google.com>
      Reviewed-by: default avatarPetr Pudlak <pudlak@google.com>
      9d1c128b
  3. 12 Sep, 2014 1 commit
  4. 14 Feb, 2014 1 commit
  5. 24 Jan, 2014 1 commit
    • Helga Velroyen's avatar
      Disabling client certificate usage · 45f75526
      Helga Velroyen authored
      This patch temporarily disables the usage of the client
      SSL certificates. The handling of RPC connections had a
      conceptional flaw, because the certificates lack a proper
      signature. For this, Ganeti needs to implement a CA,
      which is already designed (see design-x509-ca.rst) but
      not implemented yet. This patch keeps most of the
      client certificate infrastructure intact which was already
      created and and can be reused, but just disables the
      actual usage of the certificates in RPC calls till the CA
      is in place.
      Signed-off-by: default avatarHelga Velroyen <helgav@google.com>
      Reviewed-by: default avatarKlaus Aehlig <aehlig@google.com>
      45f75526
  6. 13 Jan, 2014 1 commit
  7. 10 Jan, 2014 1 commit
  8. 21 Apr, 2010 1 commit
  9. 28 Dec, 2009 1 commit
  10. 10 Oct, 2007 1 commit
    • Iustin Pop's avatar
      Remove the shebang from modules · 2f31098c
      Iustin Pop authored
      Since modules are not directly executables, remove the shebang from
      them. This helps with lintian warnings.
      
      Also make the autogenerated _autoconf.py contain two comment lines at
      the beginning, like the other modules.
      
      Reviewed-by: ultrotter
      2f31098c
  11. 16 Jul, 2007 1 commit