Commit eb9d2acc authored by Petr Pudlak's avatar Petr Pudlak

Add 'lens' Haskell dependency

.. that will be used in WConfd
Signed-off-by: default avatarPetr Pudlak <pudlak@google.com>
Reviewed-by: default avatarKlaus Aehlig <aehlig@google.com>
parent 6696f1f9
......@@ -62,18 +62,6 @@ packages, except for RBD, DRBD and Xen::
python-pyparsing python-simplejson python-bitarray \
python-pyinotify python-pycurl python-ipaddr socat fping
For older distributions (eg. Debian Squeeze) the package names are
different.::
$ apt-get install lvm2 ssh bridge-utils iproute iputils-arping make \
ndisc6 python python-pyopenssl openssl \
python-pyparsing python-simplejson python-bitarray \
python-pyinotify python-pycurl python-ipaddr socat fping
If bitarray is missing it can be installed from easy-install::
$ easy_install bitarray
Note that the previous instructions don't install optional packages.
To install the optional package, run the following line.::
......@@ -133,7 +121,7 @@ Starting with Ganeti 2.7, the Haskell GHC compiler and a few base
libraries are required in order to build Ganeti (but not to run and
deploy Ganeti on production machines). More specifically:
- `GHC <http://www.haskell.org/ghc/>`_ version 6.12 or higher
- `GHC <http://www.haskell.org/ghc/>`_ version 7 or higher
- or even better, `The Haskell Platform
<http://hackage.haskell.org/platform/>`_ which gives you a simple way
to bootstrap Haskell
......@@ -150,7 +138,7 @@ deploy Ganeti on production machines). More specifically:
- `curl <http://hackage.haskell.org/package/curl>`_, tested with
versions 1.3.4 and above
- `hslogger <http://software.complete.org/hslogger>`_, version 1.1 and
above (note that Debian Squeeze only has version 1.0.9)
above.
- `hinotify <http://hackage.haskell.org/package/hinotify>`_, tested with
version 0.3.2
- `Crypto <http://hackage.haskell.org/package/Crypto>`_, tested with
......@@ -163,6 +151,8 @@ deploy Ganeti on production machines). More specifically:
above
- `lifted-base <http://hackage.haskell.org/package/lifted-base>`_,
version 0.1.1 and above.
- `lens <http://hackage.haskell.org/package/lens>`_,
version 3.0 and above.
Some of these are also available as package in Debian/Ubuntu::
......@@ -176,12 +166,6 @@ Some of these are also available as package in Debian/Ubuntu::
libghc-attoparsec-dev libghc-vector-dev \
libghc6-zlib-dev
Or in older versions of these distributions (using GHC 6.x)::
$ apt-get install ghc6 libghc6-json-dev libghc6-network-dev \
libghc6-parallel-dev libghc6-deepseq-dev \
libghc6-curl-dev
In Fedora, some of them are available via packages as well::
$ yum install ghc ghc-json-devel ghc-network-devel \
......@@ -207,7 +191,7 @@ ones not available in your distribution packages) via ``cabal``::
$ cabal install json network parallel utf8-string curl hslogger \
Crypto text hinotify==0.3.2 regex-pcre \
attoparsec vector base64-bytestring
attoparsec vector base64-bytestring lens
Haskell optional features
~~~~~~~~~~~~~~~~~~~~~~~~~
......@@ -220,8 +204,7 @@ The extra dependency for these is:
- `snap-server` <http://hackage.haskell.org/package/snap-server>`_, version
0.8.1 and above.
This library is available in Debian Wheezy (but not in Squeeze), so you
can use either apt::
This library is available in Debian Wheezy, so you can use either apt::
$ apt-get install libghc-snap-server-dev
......@@ -231,15 +214,6 @@ or ``cabal``::
to install it.
In case you still use ghc-6.12, note that ``cabal`` would automatically try to
install newer versions of some of the libraries snap-server depends on, that
cannot be compiled with ghc-6.12, so you have to install snap-server on its
own, explicitly forcing the installation of compatible versions::
$ cabal install MonadCatchIO-transformers==0.2.2.0 mtl==2.0.1.0 \
hashable==1.1.2.0 case-insensitive==0.3 parsec==3.0.1 \
network==2.3 snap-server==0.8.1
.. _cabal-note:
.. note::
If one of the cabal packages fails to install due to unfulfilled
......
......@@ -93,6 +93,8 @@ For Haskell:
- ``lifted-base`` library (http://hackage.haskell.org/package/lifted-base)
- ``lens`` library (http://hackage.haskell.org/package/lens)
Version 2.10.0
--------------
......
......@@ -607,6 +607,7 @@ AC_GHC_PKG_REQUIRE(text)
AC_GHC_PKG_REQUIRE(hinotify)
AC_GHC_PKG_REQUIRE(Crypto)
AC_GHC_PKG_REQUIRE(lifted-base)
AC_GHC_PKG_REQUIRE(lens)
# extra modules for confd functionality; also needed for tests
HS_NODEV=
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment