Commit e5f6768c authored by Iustin Pop's avatar Iustin Pop
Browse files

Fix htools, QuickCheck library detection and tests



Just saw this while testing the migration to QuickCheck v2: while
configure.ac detects that QuickCheck-2.x is not available, the test in
Makefile.am was against WANT_HTOOLS (overall htools compilation), not
on a more-specific WANT_HTOOLSTESTS.
Signed-off-by: default avatarIustin Pop <iustin@google.com>
Reviewed-by: default avatarMichael Hanselmann <hansmi@google.com>
parent 752635d3
...@@ -665,7 +665,7 @@ dist_TESTS = \ ...@@ -665,7 +665,7 @@ dist_TESTS = \
$(python_tests) $(python_tests)
nodist_TESTS = nodist_TESTS =
if WANT_HTOOLS if WANT_HTOOLSTESTS
nodist_TESTS += $(haskell_tests) nodist_TESTS += $(haskell_tests)
endif endif
......
...@@ -431,6 +431,7 @@ AC_SUBST(HTOOLS_APIDOC) ...@@ -431,6 +431,7 @@ AC_SUBST(HTOOLS_APIDOC)
fi # end if enable_htools, define automake conditions fi # end if enable_htools, define automake conditions
AM_CONDITIONAL([WANT_HTOOLS], [test x$HTOOLS = xyes]) AM_CONDITIONAL([WANT_HTOOLS], [test x$HTOOLS = xyes])
AM_CONDITIONAL([WANT_HTOOLSTESTS], [test x$GHC_PKG_QUICKCHECK != x])
AM_CONDITIONAL([WANT_HTOOLSAPIDOC], [test x$HTOOLS_APIDOC = xyes]) AM_CONDITIONAL([WANT_HTOOLSAPIDOC], [test x$HTOOLS_APIDOC = xyes])
SOCAT_USE_ESCAPE= SOCAT_USE_ESCAPE=
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment