Commit ab6536ba authored by Michele Tartara's avatar Michele Tartara
Browse files

Update supported lint tools version numbers



Linting is now verified against the lint tools version numbers as listed in this
patch.

These version are corresponding to the ones that can be found in the
repositories of Ubuntu 13.04.
Signed-off-by: default avatarMichele Tartara <mtartara@google.com>
Reviewed-by: default avatarHelga Velroyen <helgav@google.com>
parent e0e44476
......@@ -147,15 +147,15 @@ in_chroot -- \
in_chroot -- \
easy_install \
logilab-astng==0.20.1 \
logilab-common==0.50.3 \
logilab-astng==0.24.1 \
logilab-common==0.58.3 \
mock==1.0.1 \
pylint==0.25.1
pylint==0.26.0
in_chroot -- \
easy_install \
sphinx==1.1.3 \
pep8==1.2 \
pep8==1.3.3 \
coverage==3.4 \
bitarray==0.8.0
......@@ -184,7 +184,7 @@ in_chroot -- \
cabal install --global \
hunit==1.2.5.2 \
happy==1.18.10 \
hlint==1.8.34 \
hlint==1.8.43 \
hscolour==1.20.3 \
temporary==1.1.2.3 \
test-framework==0.6.1 \
......@@ -226,7 +226,7 @@ in_chroot -- \
#Python development tools
in_chroot -- \
$APT_INSTALL pandoc python-epydoc
$APT_INSTALL python-epydoc
#Tools for creating debian packages
in_chroot -- \
......
......@@ -31,15 +31,15 @@ Note that for pylint, at the current moment the following versions
must be used::
$ pylint --version
pylint 0.25.1,
astng 0.23.1, common 0.58.0
pylint 0.26.0,
astng 0.24.1, common 0.58.3
The same with pep8, other versions may give you errors::
$ pep8 --version
1.2
1.3.3
Both these versions are the ones shipped with Debian Wheezy.
Both these versions are the ones shipped with Ubuntu 13.04.
To generate unittest coverage reports (``make coverage``), `coverage
<http://pypi.python.org/pypi/coverage>`_ needs to be installed.
......@@ -51,10 +51,10 @@ Installation of all dependencies listed here::
$ apt-get install python-yaml python-mock
$ cd / && sudo easy_install \
sphinx \
logilab-astng==0.23.1 \
logilab-common==0.58.0 \
pylint==0.25.1 \
pep8==1.2 \
logilab-astng==0.24.1 \
logilab-common==0.58.3 \
pylint==0.26.0 \
pep8==1.3.3 \
coverage
For Haskell development, again all things from the quick install
......@@ -66,7 +66,7 @@ document, plus:
used for documentation (it's source-code pretty-printing)
- `hlint <http://community.haskell.org/~ndm/hlint/>`_, a source code
linter (equivalent to pylint for Python), recommended version 1.8 or
above (tested with 1.8.15)
above (tested with 1.8.43)
- the `QuickCheck <http://hackage.haskell.org/package/QuickCheck>`_
library, version 2.x
- the `HUnit <http://hunit.sourceforge.net/>`_ library (tested with
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment