Commit 6c60b266 authored by Klaus Aehlig's avatar Klaus Aehlig
Browse files

configure: check for hslogger



As hslogger is, from 2.9 onwards, a mandatory dependency,
check for it unconditionally.
Signed-off-by: default avatarKlaus Aehlig <aehlig@google.com>
Reviewed-by: default avatarThomas Thrainer <thomasth@google.com>
parent 302ef5a1
......@@ -495,6 +495,7 @@ AC_GHC_PKG_REQUIRE(network)
AC_GHC_PKG_REQUIRE(mtl)
AC_GHC_PKG_REQUIRE(bytestring)
AC_GHC_PKG_REQUIRE(utf8-string)
AC_GHC_PKG_REQUIRE(hslogger)
# extra modules for confd functionality
HS_REGEX_PCRE=-DNO_REGEX_PCRE
......@@ -503,7 +504,6 @@ if test "$enable_confd" != no; then
CONFD_PKG=
AC_GHC_PKG_CHECK([regex-pcre], [HS_REGEX_PCRE=],
[CONFD_PKG="$CONFD_PKG regex-pcre"])
AC_GHC_PKG_CHECK([hslogger], [], [CONFD_PKG="$CONFD_PKG hslogger"])
AC_GHC_PKG_CHECK([Crypto], [], [CONFD_PKG="$CONFD_PKG Crypto"])
AC_GHC_PKG_CHECK([text], [], [CONFD_PKG="$CONFD_PKG text"])
AC_GHC_PKG_CHECK([hinotify], [], [CONFD_PKG="$CONFD_PKG hinotify"])
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment