• Iustin Pop's avatar
    htools: adjust imports for newer compilers · 7345b69b
    Iustin Pop authored
    
    
    While testing with ghc 7.2, I saw that some imports we are using are
    very old (from ghc 6.8 time), even though current libraries are using
    different names.
    
    We fix this and bump minimum documented version to ghc 6.12, as I
    don't have 6.10 to test anymore (possibly still works with that
    version, but better safe - both Ubuntu Lucid and Debian Squeeze ship
    with 6.12 nowadays).
    Signed-off-by: default avatarIustin Pop <iustin@google.com>
    Reviewed-by: default avatarMichael Hanselmann <hansmi@google.com>
    7345b69b
Hbal.hs 14.7 KB