Commit 7470ebb9 authored by Stavros Sachtouris's avatar Stavros Sachtouris
Browse files

Require astakosclient, reveal astakos commands

Refs: #4312

Since astakosclient is required, astakos commands are not need to be hidden anymore
parent 995e1f5b
...@@ -80,6 +80,7 @@ DEFAULTS = { ...@@ -80,6 +80,7 @@ DEFAULTS = {
'max_threads': 7, 'max_threads': 7,
'history_file': HISTORY_PATH, 'history_file': HISTORY_PATH,
'user_cli': 'astakos', 'user_cli': 'astakos',
'astakos_cli': 'snf-astakos',
'file_cli': 'pithos', 'file_cli': 'pithos',
'server_cli': 'cyclades', 'server_cli': 'cyclades',
'flavor_cli': 'cyclades', 'flavor_cli': 'cyclades',
...@@ -90,7 +91,6 @@ DEFAULTS = { ...@@ -90,7 +91,6 @@ DEFAULTS = {
'history_cli': 'history' 'history_cli': 'history'
# Optional command specs: # Optional command specs:
# 'livetest_cli': 'livetest', # 'livetest_cli': 'livetest',
# 'astakos_cli': 'snf-astakos'
}, },
CLOUD_PREFIX: { CLOUD_PREFIX: {
#'default': { #'default': {
......
...@@ -42,7 +42,7 @@ import kamaki ...@@ -42,7 +42,7 @@ import kamaki
optional = ['ansicolors', 'mock>=1.0.1'] optional = ['ansicolors', 'mock>=1.0.1']
requires = ['objpool>=0.2', 'progress>=1.1'] requires = ['objpool>=0.2', 'progress>=1.1', 'astakosclient>=0.14.8']
if version_info < (2, 7): if version_info < (2, 7):
requires.append('argparse') requires.append('argparse')
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment