Commit 51bfb4ac authored by Vassilis Kanellopoulos's avatar Vassilis Kanellopoulos
Browse files

Merge branch 'modular' into develop

Conflicts:
	.gitignore
	composer.json
	composer.lock
	config/.gitignore
	public/.htaccess
	public/css/style.css
	public/index.php
parents 654735e5 e64dc374
......@@ -4,8 +4,8 @@
"Read more about it at https://getcomposer.org/doc/01-basic-usage.md#composer-lock-the-lock-file",
"This file is @generated automatically"
],
"hash": "8863988d88fb32e89c7e8aeba4c3e108",
"content-hash": "cc6c039badea2210d339585b24e7bbcf",
"hash": "3d2aa0c3e50d0374e395d76f5f601939",
"content-hash": "bd78bc722c9d002c5e0c6c4a04df5ac3",
"packages": [
{
"name": "container-interop/container-interop",
......@@ -34,6 +34,47 @@
"description": "Promoting the interoperability of container objects (DIC, SL, etc.)",
"time": "2014-12-30 15:22:37"
},
{
"name": "gabordemooij/redbean",
"version": "v4.3.1",
"source": {
"type": "git",
"url": "https://github.com/gabordemooij/redbean.git",
"reference": "f1f572ddac226d047d730444927794321ee9aca6"
},
"dist": {
"type": "zip",
"url": "https://api.github.com/repos/gabordemooij/redbean/zipball/f1f572ddac226d047d730444927794321ee9aca6",
"reference": "f1f572ddac226d047d730444927794321ee9aca6",
"shasum": ""
},
"require": {
"php": ">=5.3.4"
},
"type": "library",
"autoload": {
"psr-4": {
"RedBeanPHP\\": "RedBeanPHP"
}
},
"notification-url": "https://packagist.org/downloads/",
"license": [
"New BSD and GPLv2"
],
"authors": [
{
"name": "Gabor de Mooij",
"email": "gabor@redbeanphp.com",
"homepage": "http://redbeanphp.com"
}
],
"description": "RedBeanPHP ORM",
"homepage": "http://redbeanphp.com/",
"keywords": [
"orm"
],
"time": "2015-12-28 19:46:34"
},
{
"name": "guzzlehttp/guzzle",
"version": "6.1.1",
......@@ -307,6 +348,46 @@
],
"time": "2015-03-16 10:17:44"
},
{
"name": "kanellov/php-events",
"version": "1.0.0",
"source": {
"type": "git",
"url": "https://github.com/kanellov/php-events.git",
"reference": "286e9d482b460edf106b0bb84a69f061fe93ecfa"
},
"dist": {
"type": "zip",
"url": "https://api.github.com/repos/kanellov/php-events/zipball/286e9d482b460edf106b0bb84a69f061fe93ecfa",
"reference": "286e9d482b460edf106b0bb84a69f061fe93ecfa",
"shasum": ""
},
"require": {
"php": ">=5.3"
},
"require-dev": {
"phpunit/phpunit": "3.*"
},
"type": "library",
"autoload": {
"files": [
"events.php"
]
},
"notification-url": "https://packagist.org/downloads/",
"license": [
"GNU GPLv3"
],
"authors": [
{
"name": "Vassilis Kanellopoulos",
"email": "contact@kanellov.com",
"homepage": "http://kanellov.com"
}
],
"description": "A simple events manager",
"time": "2016-02-07 21:50:29"
},
{
"name": "kanellov/slim-twig-flash",
"version": "0.1.0",
......@@ -484,16 +565,16 @@
},
{
"name": "paragonie/random_compat",
"version": "1.1.5",
"version": "v1.2.0",
"source": {
"type": "git",
"url": "https://github.com/paragonie/random_compat.git",
"reference": "dd8998b7c846f6909f4e7a5f67fabebfc412a4f7"
"reference": "b0e69d10852716b2ccbdff69c75c477637220790"
},
"dist": {
"type": "zip",
"url": "https://api.github.com/repos/paragonie/random_compat/zipball/dd8998b7c846f6909f4e7a5f67fabebfc412a4f7",
"reference": "dd8998b7c846f6909f4e7a5f67fabebfc412a4f7",
"url": "https://api.github.com/repos/paragonie/random_compat/zipball/b0e69d10852716b2ccbdff69c75c477637220790",
"reference": "b0e69d10852716b2ccbdff69c75c477637220790",
"shasum": ""
},
"require": {
......@@ -528,7 +609,7 @@
"pseudorandom",
"random"
],
"time": "2016-01-06 13:31:20"
"time": "2016-02-06 03:52:05"
},
{
"name": "pimple/pimple",
......@@ -998,6 +1079,56 @@
],
"time": "2015-06-15 19:37:28"
},
{
"name": "zendframework/zend-crypt",
"version": "2.6.0",
"source": {
"type": "git",
"url": "https://github.com/zendframework/zend-crypt.git",
"reference": "1b2f5600bf6262904167116fa67b58ab1457036d"
},
"dist": {
"type": "zip",
"url": "https://api.github.com/repos/zendframework/zend-crypt/zipball/1b2f5600bf6262904167116fa67b58ab1457036d",
"reference": "1b2f5600bf6262904167116fa67b58ab1457036d",
"shasum": ""
},
"require": {
"container-interop/container-interop": "~1.0",
"php": "^5.5 || ^7.0",
"zendframework/zend-math": "^2.6",
"zendframework/zend-stdlib": "^2.7 || ^3.0"
},
"require-dev": {
"fabpot/php-cs-fixer": "1.7.*",
"phpunit/phpunit": "~4.0"
},
"suggest": {
"ext-mcrypt": "Required for most features of Zend\\Crypt"
},
"type": "library",
"extra": {
"branch-alias": {
"dev-master": "2.6-dev",
"dev-develop": "2.7-dev"
}
},
"autoload": {
"psr-4": {
"Zend\\Crypt\\": "src/"
}
},
"notification-url": "https://packagist.org/downloads/",
"license": [
"BSD-3-Clause"
],
"homepage": "https://github.com/zendframework/zend-crypt",
"keywords": [
"crypt",
"zf2"
],
"time": "2016-02-03 23:46:30"
},
{
"name": "zendframework/zend-eventmanager",
"version": "3.0.0",
......@@ -1052,6 +1183,62 @@
],
"time": "2016-01-12 23:27:48"
},
{
"name": "zendframework/zend-filter",
"version": "2.6.1",
"source": {
"type": "git",
"url": "https://github.com/zendframework/zend-filter.git",
"reference": "202014ee64e2aae23140a1719f6d362a602713ed"
},
"dist": {
"type": "zip",
"url": "https://api.github.com/repos/zendframework/zend-filter/zipball/202014ee64e2aae23140a1719f6d362a602713ed",
"reference": "202014ee64e2aae23140a1719f6d362a602713ed",
"shasum": ""
},
"require": {
"php": "^5.5 || ^7.0",
"zendframework/zend-stdlib": "^2.7 || ^3.0"
},
"require-dev": {
"fabpot/php-cs-fixer": "1.7.*",
"pear/archive_tar": "^1.4",
"phpunit/phpunit": "~4.0",
"zendframework/zend-crypt": "^2.6",
"zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
"zendframework/zend-uri": "^2.5"
},
"suggest": {
"zendframework/zend-crypt": "Zend\\Crypt component, for encryption filters",
"zendframework/zend-i18n": "Zend\\I18n component for filters depending on i18n functionality",
"zendframework/zend-servicemanager": "Zend\\ServiceManager component, for using the filter chain functionality",
"zendframework/zend-uri": "Zend\\Uri component, for the UriNormalize filter"
},
"type": "library",
"extra": {
"branch-alias": {
"dev-master": "2.6-dev",
"dev-develop": "2.7-dev"
}
},
"autoload": {
"psr-4": {
"Zend\\Filter\\": "src/"
}
},
"notification-url": "https://packagist.org/downloads/",
"license": [
"BSD-3-Clause"
],
"description": "provides a set of commonly needed data filters",
"homepage": "https://github.com/zendframework/zend-filter",
"keywords": [
"filter",
"zf2"
],
"time": "2016-02-08 18:02:37"
},
{
"name": "zendframework/zend-hydrator",
"version": "1.0.0",
......@@ -1108,28 +1295,182 @@
],
"time": "2015-09-17 14:06:43"
},
{
"name": "zendframework/zend-inputfilter",
"version": "2.5.5",
"source": {
"type": "git",
"url": "https://github.com/zendframework/zend-inputfilter.git",
"reference": "3208cddbb92df029230cde676a5c8e5a22b531c6"
},
"dist": {
"type": "zip",
"url": "https://api.github.com/repos/zendframework/zend-inputfilter/zipball/3208cddbb92df029230cde676a5c8e5a22b531c6",
"reference": "3208cddbb92df029230cde676a5c8e5a22b531c6",
"shasum": ""
},
"require": {
"php": ">=5.5",
"zendframework/zend-filter": "~2.5",
"zendframework/zend-stdlib": "~2.5",
"zendframework/zend-validator": "^2.5.3"
},
"require-dev": {
"fabpot/php-cs-fixer": "1.7.*",
"phpunit/phpunit": "^4.5",
"zendframework/zend-i18n": "~2.5",
"zendframework/zend-servicemanager": "~2.5"
},
"suggest": {
"zendframework/zend-servicemanager": "To support plugin manager support"
},
"type": "library",
"extra": {
"branch-alias": {
"dev-master": "2.5-dev",
"dev-develop": "2.6-dev"
}
},
"autoload": {
"psr-4": {
"Zend\\InputFilter\\": "src/"
}
},
"notification-url": "https://packagist.org/downloads/",
"license": [
"BSD-3-Clause"
],
"homepage": "https://github.com/zendframework/zend-inputfilter",
"keywords": [
"inputfilter",
"zf2"
],
"time": "2015-09-03 22:31:38"
},
{
"name": "zendframework/zend-ldap",
"version": "2.6.0",
"source": {
"type": "git",
"url": "https://github.com/zendframework/zend-ldap.git",
"reference": "920863c447f167f7f1e90f982bdc2532e7a8bf24"
},
"dist": {
"type": "zip",
"url": "https://api.github.com/repos/zendframework/zend-ldap/zipball/920863c447f167f7f1e90f982bdc2532e7a8bf24",
"reference": "920863c447f167f7f1e90f982bdc2532e7a8bf24",
"shasum": ""
},
"require": {
"ext-ldap": "*",
"php": ">=5.5",
"zendframework/zend-stdlib": "~2.5"
},
"require-dev": {
"fabpot/php-cs-fixer": "1.7.*",
"php-mock/php-mock-phpunit": "~0.3",
"phpunit/phpunit": "~4.0",
"zendframework/zend-config": "~2.5",
"zendframework/zend-eventmanager": "~2.5"
},
"suggest": {
"zendframework/zend-eventmanager": "Zend\\EventManager component"
},
"type": "library",
"extra": {
"branch-alias": {
"dev-master": "2.5-dev",
"dev-develop": "2.6-dev"
}
},
"autoload": {
"psr-4": {
"Zend\\Ldap\\": "src/"
}
},
"notification-url": "https://packagist.org/downloads/",
"license": [
"BSD-3-Clause"
],
"description": "provides support for LDAP operations including but not limited to binding, searching and modifying entries in an LDAP directory",
"homepage": "https://github.com/zendframework/zend-ldap",
"keywords": [
"ldap",
"zf2"
],
"time": "2016-02-11 15:17:45"
},
{
"name": "zendframework/zend-math",
"version": "2.6.0",
"source": {
"type": "git",
"url": "https://github.com/zendframework/zend-math.git",
"reference": "395ebb981e01f2fc708ba07d8ee0d86f6e3e9ed6"
},
"dist": {
"type": "zip",
"url": "https://api.github.com/repos/zendframework/zend-math/zipball/395ebb981e01f2fc708ba07d8ee0d86f6e3e9ed6",
"reference": "395ebb981e01f2fc708ba07d8ee0d86f6e3e9ed6",
"shasum": ""
},
"require": {
"php": "^5.5 || ^7.0"
},
"require-dev": {
"fabpot/php-cs-fixer": "1.7.*",
"ircmaxell/random-lib": "~1.1",
"phpunit/phpunit": "~4.0"
},
"suggest": {
"ext-bcmath": "If using the bcmath functionality",
"ext-gmp": "If using the gmp functionality",
"ircmaxell/random-lib": "Fallback random byte generator for Zend\\Math\\Rand if OpenSSL/Mcrypt extensions are unavailable"
},
"type": "library",
"extra": {
"branch-alias": {
"dev-master": "2.6-dev",
"dev-develop": "2.7-dev"
}
},
"autoload": {
"psr-4": {
"Zend\\Math\\": "src/"
}
},
"notification-url": "https://packagist.org/downloads/",
"license": [
"BSD-3-Clause"
],
"homepage": "https://github.com/zendframework/zend-math",
"keywords": [
"math",
"zf2"
],
"time": "2016-02-02 23:15:14"
},
{
"name": "zendframework/zend-permissions-acl",
"version": "2.5.1",
"version": "2.6.0",
"source": {
"type": "git",
"url": "https://github.com/zendframework/zend-permissions-acl.git",
"reference": "7f1aac3bf99d0be8f71fe4ae79981338be8a08dc"
"reference": "843bbd9c6f6d20b84dd0ce6c815d10397e98082b"
},
"dist": {
"type": "zip",
"url": "https://api.github.com/repos/zendframework/zend-permissions-acl/zipball/7f1aac3bf99d0be8f71fe4ae79981338be8a08dc",
"reference": "7f1aac3bf99d0be8f71fe4ae79981338be8a08dc",
"url": "https://api.github.com/repos/zendframework/zend-permissions-acl/zipball/843bbd9c6f6d20b84dd0ce6c815d10397e98082b",
"reference": "843bbd9c6f6d20b84dd0ce6c815d10397e98082b",
"shasum": ""
},
"require": {
"php": ">=5.3.23"
"php": "^5.5 || ^7.0"
},
"require-dev": {
"fabpot/php-cs-fixer": "1.7.*",
"phpunit/phpunit": "~4.0",
"zendframework/zend-di": "~2.5",
"zendframework/zend-servicemanager": "~2.5"
"zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3"
},
"suggest": {
"zendframework/zend-servicemanager": "To support Zend\\Permissions\\Acl\\Assertion\\AssertionManager plugin manager usage"
......@@ -1137,8 +1478,8 @@
"type": "library",
"extra": {
"branch-alias": {
"dev-master": "2.5-dev",
"dev-develop": "2.6-dev"
"dev-master": "2.6-dev",
"dev-develop": "2.7-dev"
}
},
"autoload": {
......@@ -1156,7 +1497,7 @@
"acl",
"zf2"
],
"time": "2015-06-03 15:32:02"
"time": "2016-02-03 21:46:45"
},
{
"name": "zendframework/zend-stdlib",
......@@ -1215,6 +1556,72 @@
"zf2"
],
"time": "2015-10-15 15:57:32"
},
{
"name": "zendframework/zend-validator",
"version": "2.5.3",
"source": {
"type": "git",
"url": "https://github.com/zendframework/zend-validator.git",
"reference": "53e567a58c8952a03da0b8edf0f075303a5ac5d1"
},
"dist": {
"type": "zip",
"url": "https://api.github.com/repos/zendframework/zend-validator/zipball/53e567a58c8952a03da0b8edf0f075303a5ac5d1",
"reference": "53e567a58c8952a03da0b8edf0f075303a5ac5d1",
"shasum": ""
},
"require": {
"php": ">=5.5",
"zendframework/zend-stdlib": "~2.5"
},
"require-dev": {
"fabpot/php-cs-fixer": "1.7.*",
"phpunit/phpunit": "~4.0",
"zendframework/zend-cache": "~2.5",
"zendframework/zend-config": "~2.5",
"zendframework/zend-db": "~2.5",
"zendframework/zend-filter": "~2.5",
"zendframework/zend-http": "~2.5",
"zendframework/zend-i18n": "~2.5",
"zendframework/zend-math": "~2.5",
"zendframework/zend-servicemanager": "~2.5",
"zendframework/zend-session": "~2.5",
"zendframework/zend-uri": "~2.5"
},
"suggest": {
"zendframework/zend-db": "Zend\\Db component",
"zendframework/zend-filter": "Zend\\Filter component, required by the Digits validator",
"zendframework/zend-i18n": "Zend\\I18n component to allow translation of validation error messages as well as to use the various Date validators",
"zendframework/zend-i18n-resources": "Translations of validator messages",
"zendframework/zend-math": "Zend\\Math component",
"zendframework/zend-servicemanager": "Zend\\ServiceManager component to allow using the ValidatorPluginManager and validator chains",
"zendframework/zend-session": "Zend\\Session component",
"zendframework/zend-uri": "Zend\\Uri component, required by the Uri and Sitemap\\Loc validators"
},
"type": "library",
"extra": {
"branch-alias": {
"dev-master": "2.5-dev",
"dev-develop": "2.6-dev"
}
},
"autoload": {
"psr-4": {
"Zend\\Validator\\": "src/"
}
},
"notification-url": "https://packagist.org/downloads/",
"license": [
"BSD-3-Clause"
],
"description": "provides a set of commonly needed validators",
"homepage": "https://github.com/zendframework/zend-validator",
"keywords": [
"validator",
"zf2"
],
"time": "2015-09-03 19:06:11"
}
],
"packages-dev": [
......@@ -1377,22 +1784,24 @@
},
{
"name": "phpspec/prophecy",
"version": "v1.5.0",
"version": "v1.6.0",
"source": {
"type": "git",
"url": "https://github.com/phpspec/prophecy.git",
"reference": "4745ded9307786b730d7a60df5cb5a6c43cf95f7"
"reference": "3c91bdf81797d725b14cb62906f9a4ce44235972"
},
"dist": {
"type": "zip",
"url": "https://api.github.com/repos/phpspec/prophecy/zipball/4745ded9307786b730d7a60df5cb5a6c43cf95f7",
"reference": "4745ded9307786b730d7a60df5cb5a6c43cf95f7",
"url": "https://api.github.com/repos/phpspec/prophecy/zipball/3c91bdf81797d725b14cb62906f9a4ce44235972",
"reference": "3c91bdf81797d725b14cb62906f9a4ce44235972",
"shasum": ""
},
"require": {
"doctrine/instantiator": "^1.0.2",
"php": "^5.3|^7.0",
"phpdocumentor/reflection-docblock": "~2.0",
"sebastian/comparator": "~1.1"
"sebastian/comparator": "~1.1",
"sebastian/recursion-context": "~1.0"
},
"require-dev": {
"phpspec/phpspec": "~2.0"
......@@ -1400,7 +1809,7 @@
"type": "library",
"extra": {
"branch-alias": {
"dev-master": "1.4.x-dev"
"dev-master": "1.5.x-dev"
}
},
"autoload": {
......@@ -1433,7 +1842,7 @@
"spy",
"stub"
],
"time": "2015-08-13 10:07:40"
"time": "2016-02-15 07:46:21"
},
{
"name": "phpunit/php-code-coverage",
......@@ -1729,16 +2138,16 @@
},
{
"name": "phpunit/phpunit",
"version": "4.8.21",
"version": "4.8.23",
"source": {
"type": "git",
"url": "https://github.com/sebastianbergmann/phpunit.git",
"reference": "ea76b17bced0500a28098626b84eda12dbcf119c"
"reference": "6e351261f9cd33daf205a131a1ba61c6d33bd483"
},
"dist": {
"type": "zip",
"url": "https://api.github.com/repos/sebastianbergmann/phpunit/zipball/ea76b17bced0500a28098626b84eda12dbcf119c",
"reference": "ea76b17bced0500a28098626b84eda12dbcf119c",
"url": "https://api.github.com/repos/sebastianbergmann/phpunit/zipball/6e351261f9cd33daf205a131a1ba61c6d33bd483",
"reference": "6e351261f9cd33daf205a131a1ba61c6d33bd483",
"shasum": ""