Commit 01de400e authored by Open Source Developer's avatar Open Source Developer

Script Updates

parent 2ead3e57
......@@ -7,6 +7,8 @@ dpkg -i /tmp/StarUML-v2.8.0-32-bit.deb
dpkg -i /tmp/sublime-text_build_i386.deb
dpkg -i /tmp/code_1.12.2_i386.deb
mv /tmp/VidyoDesktopInstaller-ubuntu32bit.deb /home/ostdeveloper
mv /tmp/keys.sh /home/ostdeveloper
chmod +x /home/ostdeveloper/keys.sh
echo "deb http://ppa.launchpad.net/webupd8team/java/ubuntu xenial main" | tee /etc/apt/sources.list.d/webupd8team-java.list
echo "deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu xenial main" | tee -a /etc/apt/sources.list.d/webupd8team-java.list
mv /tmp/*.desktop /home/ostdeveloper
......
......@@ -5,7 +5,7 @@ mkdir /home/ostdeveloper/EducationSoftware/FlashPlayer
mv /home/ostdeveloper/*.desktop "/home/ostdeveloper/Επιφάνεια εργασίας"
chmod +x "/home/ostdeveloper/Επιφάνεια εργασίας/*.desktop"
uxterm -e "wget -O /home/ostdeveloper/EducationSoftware/FlashPlayer/flash_player_npapi_linux.ι386.tar.gz http://ostdev.minedu.gov.gr/~pgeorg/customDistros/developerEdition/UbuntuMate/flash_player_npapi_linux.ι386.tar.gz ; tar xvf /home/ostdeveloper/EducationSoftware/FlashPlayer/flash_player_npapi_linux.ι386.tar.gz -C /home/ostdeveloper/EducationSoftware/FlashPlayer ; echo xtremesource | sudo -S cp /home/ostdeveloper/EducationSoftware/FlashPlayer/libflashplayer.so /usr/lib/mozilla/plugins ; sudo cp -r /home/ostdeveloper/EducationSoftware/FlashPlayer/usr/* /usr ; sudo apt-get update ; sudo apt-get -y --force-yes install oracle-java8-installer ; sudo apt-get -y --force-yes install python-tk ; sudo apt-get -y --force-yes install phpmyadmin ; sudo apt-get -y --force-yes install nodejs ; sudo apt-get -y --force-yes install npm ; sudo apt-get -y --force-yes install xtightvncviewer ; sudo apt-get -y --force-yes install --reinstall ttf-mscorefonts-installer ; sudo apt-get -y --force-yes install ibus-gtk ibus-gtk3 ; sudo apt-get -y --force-yes install software-center ; sudo phpenmod mcrypt ; sudo phpenmod mbstring ; sudo dpkg -i --ignore-depends=libqt4-gui /home/ostdeveloper/VidyoDesktopInstaller-ubuntu32bit.deb ; sudo dpkg --add-architecture i386 ; sudo apt-get update ; sudo gpasswd -a ostdeveloper epoptes ; gsettings set org.mate.panel.toplevel:/org/mate/panel/toplevels/top/ orientation bottom ; gsettings set org.mate.panel.toplevel:/org/mate/panel/toplevels/top/ size 20 ; gsettings set org.mate.panel.toplevel:/org/mate/panel/toplevels/bottom/ size 20 ; gsettings set org.freedesktop.ibus.general use-system-keyboard-layout true ; gsettings set org.freedesktop.ibus.panel show-icon-on-systray false ; gsettings set org.mate.caja.desktop computer-icon-visible true ; gsettings set org.mate.caja.desktop network-icon-visible true ; gsettings set org.mate.caja.desktop trash-icon-visible true ; rm /home/ostdeveloper/.config/autostart/RunME.desktop ; rm /home/ostdeveloper/Επιφάνεια\ εργασίας/RunME.desktop ; sudo dpkg --configure -a ; reboot"
uxterm -e "wget -O /home/ostdeveloper/EducationSoftware/FlashPlayer/flash_player_npapi_linux.ι386.tar.gz http://ostdev.minedu.gov.gr/~pgeorg/customDistros/developerEdition/UbuntuMate/flash_player_npapi_linux.ι386.tar.gz ; tar xvf /home/ostdeveloper/EducationSoftware/FlashPlayer/flash_player_npapi_linux.ι386.tar.gz -C /home/ostdeveloper/EducationSoftware/FlashPlayer ; echo xtremesource | sudo -S cp /home/ostdeveloper/EducationSoftware/FlashPlayer/libflashplayer.so /usr/lib/mozilla/plugins ; sudo cp -r /home/ostdeveloper/EducationSoftware/FlashPlayer/usr/* /usr ; sudo apt-get update ; sudo apt-get -y --force-yes install oracle-java8-installer ; sudo apt-get -y --force-yes install python-tk ; sudo apt-get -y --force-yes install phpmyadmin ; sudo apt-get -y --force-yes install nodejs ; sudo apt-get -y --force-yes install npm ; sudo apt-get -y --force-yes install xtightvncviewer ; sudo apt-get -y --force-yes install ibus-gtk ibus-gtk3 ; sudo apt-get -y --force-yes install software-center ; sudo apt-get -y --force-yes install skype ; sudo /bin/sh /home/ostdeveloper/keys.sh ; sudo phpenmod mcrypt ; sudo phpenmod mbstring ; sudo dpkg --add-architecture i386 ; sudo apt-get update ; sudo dpkg -i --ignore-depends=libqt4-gui /home/ostdeveloper/VidyoDesktopInstaller-ubuntu32bit.deb ; sudo gpasswd -a ostdeveloper epoptes ; gsettings set org.mate.panel.toplevel:/org/mate/panel/toplevels/top/ orientation bottom ; gsettings set org.mate.panel.toplevel:/org/mate/panel/toplevels/top/ size 20 ; gsettings set org.mate.panel.toplevel:/org/mate/panel/toplevels/bottom/ size 20 ; gsettings set org.freedesktop.ibus.general use-system-keyboard-layout true ; gsettings set org.freedesktop.ibus.panel show-icon-on-systray false ; gsettings set org.mate.caja.desktop computer-icon-visible true ; gsettings set org.mate.caja.desktop network-icon-visible true ; gsettings set org.mate.caja.desktop trash-icon-visible true ; rm /home/ostdeveloper/.config/autostart/RunME.desktop ; rm /home/ostdeveloper/Επιφάνεια\ εργασίας/RunME.desktop ; sudo dpkg --configure -a ; reboot"
#!/usr/bin/env xdg-open
[Desktop Entry]
Name=Skype
Comment=Skype Internet Telephony
Exec=env PULSE_LATENCY_MSEC=60 skype %U
Icon=skype.png
Terminal=false
Type=Application
Encoding=UTF-8
Categories=Network;Application;
MimeType=x-scheme-handler/skype;
X-KDE-Protocols=skype
......@@ -44,4 +44,4 @@ deb http://security.ubuntu.com/ubuntu xenial-security universe
deb http://security.ubuntu.com/ubuntu xenial-security multiverse
# deb-src http://security.ubuntu.com/ubuntu xenial-security multiverse
deb http://gr.archive.ubuntu.com/ubuntu precise main universe
deb http://archive.canonical.com/ubuntu zesty partner
......@@ -381,7 +381,7 @@ tasksel tasksel/first multiselect ubuntu-desktop
#d-i pkgsel/install-language-support boolean true
#d-i pkgsel/language-pack-patterns string el_GR
# Individual additional packages to install
d-i pkgsel/include string openssh-client openssh-server mysql-server mysql-client putty php7.0 php7.0-curl php7.0-cgi php-mbstring php-gettext build-essential vim less git subversion default-jdk rsync curl xterm x11-utils xorg ubuntu-mate-desktop apache2 libapache2-mod-php libapache2-mod-php7.0 filezilla ubuntu-software python-pip sshfs q4wine flashplugin-installer alien python3-dev gparted gsfonts-x11 netbeans isomaster virtualbox ninja-ide k3b libxss1 libgconf2-4 libappindicator1 libindicator7 python-software-properties nano epoptes chromium-browser
d-i pkgsel/include string openssh-client openssh-server mysql-server mysql-client putty php7.0 php7.0-curl php7.0-cgi php-mbstring php-gettext build-essential vim less git subversion default-jdk rsync curl xterm x11-utils xorg ubuntu-mate-desktop apache2 libapache2-mod-php libapache2-mod-php7.0 filezilla ubuntu-software python-pip sshfs q4wine flashplugin-installer alien python3-dev gparted apt-transport-https whois gsfonts-x11 netbeans isomaster virtualbox ninja-ide k3b libxss1 libgconf2-4 libappindicator1 libindicator7 python-software-properties nano epoptes chromium-browser
# Whether to upgrade packages after debootstrap.
# Allowed values: none, safe-upgrade, full-upgrade
......
echo xtremesource | sudo -S rm /etc/ssh/sshhostdsakey ; sudo rm /etc/ssh/sshhostrsakey ; sudo rm /etc/ssh/sshhostecdsa_key ; sudo ssh-keygen -t dsa -N "" -f /etc/ssh/sshhostdsakey ; sudo ssh-keygen -t rsa -N "" -f /etc/ssh/sshhostrsakey ; sudo ssh-keygen -t ecdsa -N "" -f /etc/ssh/sshhostecdsa_key
......@@ -8,6 +8,8 @@ dpkg -i /tmp/StarUML-v2.8.0-64-bit.deb
dpkg -i /tmp/sublime-text_build_amd64.deb
dpkg -i /tmp/code_1.12.2_amd64.deb
mv /tmp/VidyoDesktopInstaller-ubuntu64bit.deb /home/ostdeveloper
mv /tmp/keys.sh /home/ostdeveloper
chmod +x /home/ostdeveloper/keys.sh
echo "deb http://ppa.launchpad.net/webupd8team/java/ubuntu xenial main" | tee /etc/apt/sources.list.d/webupd8team-java.list
echo "deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu xenial main" | tee -a /etc/apt/sources.list.d/webupd8team-java.list
mv /tmp/*.desktop /home/ostdeveloper
......
......@@ -5,7 +5,7 @@ mkdir /home/ostdeveloper/EducationSoftware/FlashPlayer
mv /home/ostdeveloper/*.desktop "/home/ostdeveloper/Επιφάνεια εργασίας"
chmod +x "/home/ostdeveloper/Επιφάνεια εργασίας/*.desktop"
uxterm -e "wget -O /home/ostdeveloper/EducationSoftware/FlashPlayer/flash_player_npapi_linux.x86_64.tar.gz http://ostdev.minedu.gov.gr/~pgeorg/customDistros/developerEdition/UbuntuMate/flash_player_npapi_linux.x86_64.tar.gz ; tar xvf /home/ostdeveloper/EducationSoftware/FlashPlayer/flash_player_npapi_linux.x86_64.tar.gz -C /home/ostdeveloper/EducationSoftware/FlashPlayer ; echo xtremesource |sudo -S cp /home/ostdeveloper/EducationSoftware/FlashPlayer/libflashplayer.so /usr/lib/mozilla/plugins ; sudo cp -r /home/ostdeveloper/EducationSoftware/FlashPlayer/usr/* /usr ; sudo apt-get update ; sudo apt-get -y --force-yes install oracle-java8-installer ; sudo apt-get -y --force-yes install python-tk ; sudo apt-get -y --force-yes install phpmyadmin ; sudo apt-get -y --force-yes install nodejs ; sudo apt-get -y --force-yes install npm ; sudo apt-get -y --force-yes install xtightvncviewer ; sudo apt-get -y --force-yes install --reinstall ttf-mscorefonts-installer ; sudo apt-get -y --force-yes install ibus-gtk ibus-gtk3 ; sudo apt-get -y --force-yes install software-center ; sudo phpenmod mcrypt ; sudo phpenmod mbstring ; sudo dpkg -i --ignore-depends=libqt4-gui /home/ostdeveloper/VidyoDesktopInstaller-ubuntu64bit.deb ; sudo dpkg --add-architecture i386 ; sudo apt-get update ; sudo gpasswd -a ostdeveloper epoptes ; gsettings set org.mate.panel.toplevel:/org/mate/panel/toplevels/top/ orientation bottom ; gsettings set org.mate.panel.toplevel:/org/mate/panel/toplevels/top/ size 20 ; gsettings set org.mate.panel.toplevel:/org/mate/panel/toplevels/bottom/ size 20 ; gsettings set org.freedesktop.ibus.general use-system-keyboard-layout true ; gsettings set org.freedesktop.ibus.panel show-icon-on-systray false ; gsettings set org.mate.caja.desktop computer-icon-visible true ; gsettings set org.mate.caja.desktop network-icon-visible true ; gsettings set org.mate.caja.desktop trash-icon-visible true ; rm /home/ostdeveloper/.config/autostart/RunME.desktop ; rm /home/ostdeveloper/Επιφάνεια\ εργασίας/RunME.desktop ; sudo dpkg --configure -a ; reboot"
uxterm -e "wget -O /home/ostdeveloper/EducationSoftware/FlashPlayer/flash_player_npapi_linux.x86_64.tar.gz http://ostdev.minedu.gov.gr/~pgeorg/customDistros/developerEdition/UbuntuMate/flash_player_npapi_linux.x86_64.tar.gz ; tar xvf /home/ostdeveloper/EducationSoftware/FlashPlayer/flash_player_npapi_linux.x86_64.tar.gz -C /home/ostdeveloper/EducationSoftware/FlashPlayer ; echo xtremesource | sudo -S cp /home/ostdeveloper/EducationSoftware/FlashPlayer/libflashplayer.so /usr/lib/mozilla/plugins ; sudo cp -r /home/ostdeveloper/EducationSoftware/FlashPlayer/usr/* /usr ; sudo apt-get update ; sudo apt-get -y --force-yes install oracle-java8-installer ; sudo apt-get -y --force-yes install python-tk ; sudo apt-get -y --force-yes install phpmyadmin ; sudo apt-get -y --force-yes install nodejs ; sudo apt-get -y --force-yes install npm ; sudo apt-get -y --force-yes install xtightvncviewer ; sudo apt-get -y --force-yes install ibus-gtk ibus-gtk3 ; sudo apt-get -y --force-yes install software-center ; sudo apt-get -y --force-yes install skype ; sudo phpenmod mcrypt ; sudo phpenmod mbstring ; sudo dpkg --add-architecture i386 ; sudo apt-get update ; sudo /bin/sh /home/ostdeveloper/keys.sh ; sudo dpkg -i --ignore-depends=libqt4-gui /home/ostdeveloper/VidyoDesktopInstaller-ubuntu64bit.deb ; sudo gpasswd -a ostdeveloper epoptes ; gsettings set org.mate.panel.toplevel:/org/mate/panel/toplevels/top/ orientation bottom ; gsettings set org.mate.panel.toplevel:/org/mate/panel/toplevels/top/ size 20 ; gsettings set org.mate.panel.toplevel:/org/mate/panel/toplevels/bottom/ size 20 ; gsettings set org.freedesktop.ibus.general use-system-keyboard-layout true ; gsettings set org.freedesktop.ibus.panel show-icon-on-systray false ; gsettings set org.mate.caja.desktop computer-icon-visible true ; gsettings set org.mate.caja.desktop network-icon-visible true ; gsettings set org.mate.caja.desktop trash-icon-visible true ; rm /home/ostdeveloper/.config/autostart/RunME.desktop ; rm /home/ostdeveloper/Επιφάνεια\ εργασίας/RunME.desktop ; sudo dpkg --configure -a ; reboot"
#!/usr/bin/env xdg-open
[Desktop Entry]
Name=Skype
Comment=Skype Internet Telephony
Exec=env PULSE_LATENCY_MSEC=60 skype %U
Icon=skype.png
Terminal=false
Type=Application
Encoding=UTF-8
Categories=Network;Application;
MimeType=x-scheme-handler/skype;
X-KDE-Protocols=skype
......@@ -6,4 +6,4 @@ Terminal=false
Name=Software Center
Comment=Ubuntu Application Store
Exec=/usr/bin/software-center %u
Icon=/usr/share/icons/matefaenza/apps/96/softwarecenter.png
Icon=/usr/share/icons/matefaenza/apps/scalable/softwarecenter.svg
......@@ -44,4 +44,4 @@ deb http://security.ubuntu.com/ubuntu xenial-security universe
deb http://security.ubuntu.com/ubuntu xenial-security multiverse
# deb-src http://security.ubuntu.com/ubuntu xenial-security multiverse
deb http://gr.archive.ubuntu.com/ubuntu precise main universe
deb http://archive.canonical.com/ubuntu zesty partner
......@@ -381,7 +381,7 @@ tasksel tasksel/first multiselect ubuntu-desktop
#d-i pkgsel/install-language-support boolean true
#d-i pkgsel/language-pack-patterns string el_GR
# Individual additional packages to install
d-i pkgsel/include string openssh-client openssh-server mysql-server mysql-client putty php7.0 php7.0-curl php7.0-cgi php-mbstring php-gettext build-essential vim less git subversion default-jdk rsync curl xterm x11-utils xorg ubuntu-mate-desktop apache2 libapache2-mod-php libapache2-mod-php7.0 filezilla ubuntu-software python-pip sshfs q4wine flashplugin-installer alien python3-dev gparted gsfonts-x11 netbeans isomaster virtualbox ninja-ide k3b libxss1 libgconf2-4 libappindicator1 libindicator7 python-software-properties nano epoptes
d-i pkgsel/include string openssh-client openssh-server mysql-server mysql-client putty php7.0 php7.0-curl php7.0-cgi php-mbstring php-gettext build-essential vim less git subversion default-jdk rsync curl xterm x11-utils xorg ubuntu-mate-desktop apache2 libapache2-mod-php libapache2-mod-php7.0 filezilla ubuntu-software python-pip sshfs q4wine flashplugin-installer alien python3-dev gparted apt-transport-https whois gsfonts-x11 netbeans isomaster virtualbox ninja-ide k3b libxss1 libgconf2-4 libappindicator1 libindicator7 python-software-properties nano epoptes
# Whether to upgrade packages after debootstrap.
# Allowed values: none, safe-upgrade, full-upgrade
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment